Version 3:
  - Updated ovsdb_datum_find_key() signature to return a boolean result
    and the position as an argument.
  - Added a few extra comments.
  - Re-organized subtraction to use 'start_idx' in 2 places and to set
    it in a more readable way.
  - Other small adjustments for code clarity.
  - Added a new patch with a new implementation for diff application.
    It's not strictly about set operations, but it depends on the function
    inroduced here and largly siimlar to other patches, so it make some
    sense to send them together.

Version 2:
  - Added a new patch with optimized subtraction.

Ilya Maximets (3):
  ovsdb-data: Optimize union of sets.
  ovsdb-data: Optimize subtraction of sets.
  ovsdb-datum: Add function to apply diff in-place.

 lib/db-ctl-base.c   |  28 ++---
 lib/ovsdb-data.c    | 256 ++++++++++++++++++++++++++++++++++++--------
 lib/ovsdb-data.h    |  16 ++-
 lib/ovsdb-idl.c     |  29 +++--
 ovsdb/file.c        |  10 +-
 ovsdb/mutation.c    |   2 +-
 tests/ovsdb-data.at |  12 +++
 tests/test-ovsdb.c  |  17 +++
 vswitchd/bridge.c   |   6 +-
 9 files changed, 285 insertions(+), 91 deletions(-)

-- 
2.31.1

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to