v1: initial series
v2: change tunnel port naming scheme: include "chassis index" instead of
its name for source chassis.
v2: formatting adjustments.
v3: fixed build due to ovs_abort missing arguments.
v3: added documentation to CLI and system-id-override file.
v3: added documentation for chassis specific db config options.
v3: documented the ability to run multiple controllers on the same host,
while mentioning that this support is highly experimental.
v3: updated NEWS file to include the note about the new experimental
issue.
v3: rebased.
v4: fixed a memory leak in get_chassis_idx.
v5: actually fix the leak...
Ihar Hrachyshka (7):
Include "chassis index" into tunnel port name
Support ovn-...-<chassis> specific global ovsdb options
Allow to override system-id via file
Support passing chassis name via CLI
Don't touch tunnel ports from a different br-int
Add connectivity test for 2 controllers on the same host
Document experimental support for co-hosted controllers
NEWS | 2 +
controller/chassis.c | 164 ++++++++++------
controller/chassis.h | 9 +-
controller/encaps.c | 85 +++++----
controller/encaps.h | 3 +-
controller/ovn-controller.8.xml | 31 +++-
controller/ovn-controller.c | 226 +++++++++++++++++------
controller/patch.c | 6 +-
controller/physical.c | 2 +-
lib/ovn-util.c | 87 +++++++++
lib/ovn-util.h | 26 +++
tests/automake.mk | 1 +
tests/ovn-macros.at | 6 +-
tests/ovn.at | 318 ++++++++++++++++++++++++++++++++
tests/ovs-macros.at | 2 +
15 files changed, 815 insertions(+), 153 deletions(-)
--
2.34.3
_______________________________________________
dev mailing list
[email protected]
https://mail.openvswitch.org/mailman/listinfo/ovs-dev