GCC 14 renamed one of the AVX512 defines to have only single
underscore instead of two [0]. Add the single underscore define to
keep compatibility with multiple GCC versions.

[0] 
https://github.com/gcc-mirror/gcc/commit/aea8e4105553cd16799f2134d15420ccf182d732
Tested-by: Dumitru Ceara <dce...@redhat.com>
Signed-off-by: Ales Musil <amu...@redhat.com>
---
 include/sparse/immintrin.h | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/include/sparse/immintrin.h b/include/sparse/immintrin.h
index dd742be9f..36b41d352 100644
--- a/include/sparse/immintrin.h
+++ b/include/sparse/immintrin.h
@@ -26,5 +26,9 @@
 #define _KEYLOCKERINTRIN_H_INCLUDED
 #define __AVX512FP16INTRIN_H_INCLUDED
 #define __AVX512FP16VLINTRIN_H_INCLUDED
+/* GCC >=14 changed the "__AVX512FP16INTRIN_H_INCLUDED" to have only single
+ * underscore. We need both to keep compatibility between various GCC
+ * versions. */
+#define _AVX512FP16INTRIN_H_INCLUDED
 
 #include_next <immintrin.h>
-- 
2.44.0

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to