https://bugzilla.redhat.com/show_bug.cgi?id=2278424



--- Comment #13 from Jerry James <[email protected]> ---
(In reply to Zbigniew Jędrzejewski-Szmek from comment #12)
> Maybe like this:
> features=(
>   %{?with_test:"testing"}
>   %{?with_doc:"rtd"}
> )
> features=$(IFS=,; echo "${features[*]}")
> %pyproject_buildrequires ${features:+-x ${features}}
> 
> It's longer, but I think it's more readable. It also scales to more than two
> "features".
> (I know this doesn't matter :))

That's certainly clever.  I'm not sure it's more readable, though.  I guess it
depends on who is doing the reading. :-)  I'll think about this before I import
the package.

> One more suggestion: add '-v' to %pytest so that individual test names are
> printed.

Yes, good idea.  Thank you for the quick review!


-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are always notified about changes to this product and component
https://bugzilla.redhat.com/show_bug.cgi?id=2278424

Report this comment as SPAM: 
https://bugzilla.redhat.com/enter_bug.cgi?product=Bugzilla&format=report-spam&short_desc=Report%20of%20Bug%202278424%23c13

-- 
_______________________________________________
package-review mailing list -- [email protected]
To unsubscribe send an email to [email protected]
Fedora Code of Conduct: 
https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: 
https://lists.fedoraproject.org/archives/list/[email protected]
Do not reply to spam, report it: 
https://pagure.io/fedora-infrastructure/new_issue

Reply via email to