In perl.git, the annotated tag v5.17.0 has been created

<http://perl5.git.perl.org/perl.git/commitdiff/aca8d19feb348b88fde0b018584caa2f40790d69?hp=0000000000000000000000000000000000000000>

        at  aca8d19feb348b88fde0b018584caa2f40790d69 (tag)
   tagging  028eed19bd6ad7850c893dc1b88d33f63b0fe122 (commit)
  replaces  v5.16.0
 tagged by  Zefram
        on  Sat May 26 15:50:45 2012 +0100

- Log -----------------------------------------------------------------
Perl 5.17.0

Alan Haggai Alavi (1):
      Removed a redundant 'once'

Aristotle Pagaltzis (1):
      [perl #112522] Mildly incorrect wording in "perldoc perlre"

Brian Fraser (2):
      Fix for [perl #8931], call magic only once for join's first arg.
      Test case for [perl #9391]

Chris 'BinGOs' Williams (1):
      Synchronise Module-CoreList in Maintainers.pl with teh CPAN

Craig A. Berry (13):
      [perl #112786] Fix build under clang++
      Unmangle mathoms under C++.
      The reentrant API should always have prototypes.
      Use the (START|END)_EXTERN_C macros.
      Fix up vms/vms.c for C++.
      C++ification for vms/vmsish.h.
      File scope for VMS-specific #includes.
      VMS C++ strerror prototype differences in perl.h.
      Make configure.com ready for C++.
      Fix a cast in vms/vms.c.
      Accumulate access warnings in stat.t.
      Fix varying string struct for VMS's home-grown glob.
      __DECCXX usually should do what __DECC does.

Dagfinn Ilmari Mannsåker (1):
      Don't warn about "ambiguous without parens" for ctrl-glob

Eric Brine (2):
      [perl #112692] perlfunc: waitpid takes two args
      Purported equivalency isn't.

Father Chrysostomos (128):
      Make filetest ops fiddle the stack less
      pp.h: Missing macro parentheses
      Make -t BAREWORD extend the stack
      Move stack extension into FT_* macros
      pp_sys.c: Remove SPAGAIN after my_(l)stat_flags
      pp_sys.c:S_try_amagic_ftest: Remove SPAGAIN
      [Merge] Filetest refactoring
      Fix non-GCC compilation
      pp_hot.c:pp_entersub: Rmv comment about setting PL_compcv
      regen/opcodes: Rmv evalonce comment
      Corrections to AUTHORS should go to perlbug
      Increase $B::Concise::VERSION to 0.90
      Teach B::Concise about UTF8 labels
      [perl #111794] Make goto "" like goto ${\""}
      Produce the right error for goto "\0"
      pp_ctl.c:pp_goto: Don’t repeat yourself
      Increase $XS::APItest::VERSION to 0.39
      XS-APItest/t/hash.t: comment typo
      mg.c:magic_clearhint: remove redundant PERL_UNUSED_ARG
      [perl #111000] Let hv_store work on hint hashes
      Copy call checker when cloning closure prototype
      perldata: Consistent spaces after dots
      [perl #112184] Handle $^N in Perl_magic_set
      Remove todo for UTF8 source filters
      Increase $Storable::VERSION to 2.35
      [perl #112358] Storable: Don’t create RV with no refcnt
      Increase $File::Find::VERSION to 1.21
      File::Find: typo
      Increase $Hash::Util::VERSION to 0.12
      [perl #112418] Fix POD paragraph formatting
      scope.c: Simplify and clarify comment
      Make lvalue subs copy returned PADTMPs in rvalue cx
      Increase $File::DosGlob::VERSION to 1.07
      Remove obsolete comment from DosGlob.pm
      DosGlob.pm: Fix pod syntax
      Correct comment typo in op.h
      Don’t let method-BLOCK read beyond the stack
      feature.pl: Make 5.even bundle imply 5.odd
      Don’t stringify GV in numeric cx outside warnings scope
      perldiag: Rewrap symref error for better splain output
      checkAUTHORS.pl: Another address for Matthew Horsfall
      To-do tests for method/isa/overload updates and overloading
      Move SvAMAGIC flag from object to stash
      Don’t check PL_amagic_generation in Gv_AMG
      Don’t incr PL_amagic_generation in universal.c
      sv.h: Add HvAMAGIC macros
      sv.h: Turn off AMAGIC flag in Gv_AMG
      sv.h: define SvAMAGIC in terms of HvAMAGIC
      gv.c: Check overload tables when overloading is used
      overload.t: Another to-do test for isa changes
      [perl #112708] Update overloadedness with ‘use overload’
      overload.t: Move some tests above ‘keep last’ test
      Make @ISA changes update overloadedness
      Increase $overload::VERSION to 1.19
      Correct comment typo in overload.t
      overload.t: Tests for no overload "fallback"
      Make overloaded classes inherit fallback
      overload.pm: Don’t touch %OVERLOAD’s dummy entry
      Make ‘no overload’ also warn about invalid args
      sv.c: Don’t fiddle with AMAGIC in sv_bless
      sv.c: Don’t do SvAMAGIC_off in sv_setsv_flags
      sv.c: Don’t do SvAMAGIC_off in newSVrv
      Don’t magicalise %OVERLOAD
      Annihilate ‘A’ magic
      Consign magic_setamagic to oblivion
      Update overload docs
      overload.pm: This warning exists now
      overload.t: Move a test
      overload.t: Translate a comment into English :-)
      overload.t: Make the undef %overload:: test useful
      overload.pm: Allow :: in method names
      Check HvNAME in Gv_AMG
      Correct Peek.t to account for flag changes
      [Merge] Update overload caches properly
      Make pos(@array) and pos(%hash) into errors
      Make cproto.t more stringent
      cproto.t: Add tests for BEGIN, etc.
      Test <> ovrld with glob override
      op.c:ck_glob: Check PL_globhook before loading File::Glob
      op.c: Remove a redundant ck_subr call from dofile
      op.c: Remove a redundant ck_subr call from ck_glob
      op.c: Remove a redundant ck_subr call from ck_require
      op.c:ck_glob: Don’t do gv_fetchpv("CORE::GLOBAL::glob")
      coreamp.t: rename badly-named tests
      Remove OPpCONST_WARNING
      Remove OPpCONST_WARNING from B::Concise
      Allow require_errors.t to be run from the top level
      require_errors.t: Test <> error
      override.t: Remove obsolete comment
      Make while(each ...) imply defined($_ = ...)
      Test that ‘require v5’ ignores sub named v5
      Don’t crash with &CORE::foo after undefining *_
      op.c: Remove redundant assignment
      Consistent spaces after dots in CORE.pod
      Remove double space from Pod::Functions descr
      Increase $Pod::Functions::VERSION to 1.06
      perldelta for goto ""
      perldelta for goto "\0"
      perldelta for hvstore and %^H
      perldelta for copying call checkers to closures
      perldelta for setting $^N
      perldelta for modding $_[0] in STORABLE_freeze
      perldelta for Hash::Util changes
      perldelta for undef *^H non-ambiguity
      perldelta for CORE:: and TARG
      perldelta for method{}
      perldelta for File::stat -r warning
      perldelta for vec w/2GB offsets
      perldelta for File::stat’s -p
      perldelta for changed AMAGIC table mechanism
      perldelta for overload caching bug fixes
      perldelta for overload fallback inheritance
      perldelta for ‘no overload "invalid"’ warnings
      perldelta for pos %foo
      perldelta for while(each %h)
      perldelta for undef *_, &CORE::time crash
      Add Igor Zaytsev to AUTHORS
      perlfunc: long lines
      op.c: One less func call for newXS
      Excise PL_amagic_generation
      ParseXS.pm: Only inc PL_amagic_generation before 5.9
      Increase $ExtUtils::ParseXS::VERSION to 3.17
      Increase $ExtUtils::ParseXS::Utilities::VERSION to 3.17
      [perl #113050] Put fallback back under "()"
      perldelta for PL_amagic_generation removal
      Correct perldelta entry for fallback entry
      Add another address for Ronald Kimball to checkAUTHORS.pl
      perldelta updates

Igor Zaytsev (1):
      [perl #111918] Fix thawing seen objects in STORABLE_attach hook

Karl Williamson (41):
      mktables: Defer accepting Unicode's BELL character
      mk_PL_charclass.pl: Don't use \w, \s
      Experimentally add VT to \s definition
      perlfunc: Add reference to simple folding docs
      doio.c: Add some comments
      embed.fnc: Change formal param name to match docs
      utf8.h: Comment improvementes, white-space
      utf8.h: Simplify expressions
      utf8.h, pp.c: Add UTF8_IS_REPLACEMENT macro, and use it
      utf8.c: Extra branch to avoid others in the typical case
      utf8.c: Remove unnecessary validation
      utf8.c: Skip extraneous function call
      podcheck.t: Allow checking old perldelta
      utf8n_to_uvuni(): Add a few compiler hints
      utf8.c: Add comment
      regexec.c: Don't allow malformations under EBCDIC
      pp_pack.c: Use macro instead of its expansion
      regcomp.c: Wrap long comment to 80 columns
      utf8.c: Re-order if branches for speed
      regexec.c: Use foldcase instead of lower/upper
      utf8.c: Add assertion
      utf8.c: Add nomix-ASCII option to to_fold functions
      handy.h: New defn of isOCTAL_A() to free up bit
      regcomp.c: #define shorter synonym
      perlebcdic: remove trailing white space
      perlebcdic: Add a few commas for clarity
      perlebcdic: Narrow table to fit in 79 columns
      regen/mk_invlists.pl: Fail if inversion list not found
      perlebcdic: make verbatim line fit in 79 cols
      podcheck.t: Add label to 'next' stmts for clarity
      podcheck.t: Try harder to avoid transitory failure
      mktables: Add overloaded '+='
      mktables: Add error check
      mktables: Add overloaded .=
      mktables: Add sanity check
      Revert "Fix mktables bug due to the previous overload fix"
      mktables: Handle typo in Unicode 6.1 data file
      Add perldelta for Unicode CCC132 fix
      handy.h: Fix definition of isOCTAL_A()
      utf8.pm: pod: grammar, clarify
      Deprecate literal unescaped "{" in regexes.

Leon Timmermans (1):
      Block signals during fork (fixes RT#82580)

Lukas Mai (1):
      document behavior of duplicate keys in hash assignment

Marcus Holland-Moritz (1):
      [perl #60204] Unhelpful error message from unpack

Matthew Horsfall (alh) (1):
      Fix --authors to work and fix documentation as well.

Moritz Lenz (1):
      [perlfunc] fix usage of wait

Rafael Garcia-Suarez (3):
      Lookup overloaded assignment operators when trying to swap the arguments
      Fix mktables bug due to the previous overload fix
      Merge branch 'rgs/overload' into blead

Reini Urban (1):
      replace B::COP::stashflags by B::COP::stashlen

Ricardo Signes (13):
      add the 5.16.0 epigraph
      include some more data in new-perldelta output
      create the new perldelta for 5.17.0
      bump version to 5.17.0
      uconfig regen needed after version bump!
      add the 5.17 feature bundle
      there are no longer any scheduled 5.12 releases
      update the release schedule for 5.16, 5.17, 5.18
      update the release schedule: 5.16 is 2012-2013
      remove Version-Requirements from core!
      Revert "t/porting/checkcase.t should skip directories"
      perldelta: Version::Requirements has been removed
      add Version::Requirements as a known linkable-to lib

Robin Barker (via RT) (1):
      refactor macro to avoid compiler warning in regcomp.c

Ronald J Kimball (1):
      [perl #112604] perlre man page contains suspect example of recursion

Smylers (1):
      Make symbolic references diagnostic less cryptic

Steffen Mueller (1):
      Make CV * typemap entry support overloading

Steve Hay (1):
      Close the filehandle actually being tested in uni/readline.t

Tony Cook (9):
      [rt #111640] TODO tests for warnings from -X on File::stat
      [rt #111640] warn on the right -X operators used on a File::stat object
      add a directory of tests to run with large available memory
      [rt #100514] regression test for read() with a 2Gib offset
      [rt #111730] TODO tests for vec() with large offsets
      [rt #111730] don't use I32 for offsets in vec()
      [perl #111638] TODO for -p on a File::stat object
      [perl #111638] fix -p on File::stat objects
      document the return value of pipe()

Zefram (14):
      correct schedule for 5.17.0 release
      perldelta updates
      perldelta updates
      perldelta updates
      fix comparative Perl version numbers
      remove deprecated qw-as-parens behaviour
      correct pluralisation for "1 week"
      finalise perldelta
      handle JSON meta files on CPAN
      handle hash form of bugtracker resource data
      note Module::CoreList issue with .0 versions
      update Module::CoreList for 5.17.0
      add new release to perlhist
      fix perlhist entry for 5.16.0

jkeenan (5):
      Individual files may appear in list of directories to be searched.
      Individual files may appear in list of directories to be searched.
      Add subroutines hash_locked() and hashref_locked() to Hash::Util.
      Document hashref_locked() and hashref_unlocked().  Add tests for them, 
include debugging by Father C++.
      Correct spelling error reported by rrt.

-----------------------------------------------------------------------

--
Perl5 Master Repository

Reply via email to