Branch: refs/heads/blead
Home: https://github.com/Perl/perl5
Commit: 8eb13beb49495e289b9b7a824baa05d46328aa4f
https://github.com/Perl/perl5/commit/8eb13beb49495e289b9b7a824baa05d46328aa4f
Author: Lukas Mai <[email protected]>
Date: 2024-07-04 (Thu, 04 Jul 2024)
Changed paths:
M pp_sys.c
Log Message:
-----------
pp_chdir: simplify control flow in fchdir case
The result is (in my opinion) easier to read. It also lets us get rid
of:
- two levels of indentation
- three `goto`s and a label
- one duplicate instance of `PUSHs(boolSV(fchdir(...) >= 0))`
- one `#ifdef ... #endif` section
To unsubscribe from these emails, change your notification settings at
https://github.com/Perl/perl5/settings/notifications