Tom Christiansen wrote:
>
>     $count = getpwnam("tchrist")/l;
>     $count = getpwnam("tchrist", LIST);
>     $count = getpwnam("tchrist")->as_list;
> 
> All of those, frankly, suck.  This is much better:
> 
>     $count = () = getpwnam("tchrist");

Hmmm. I agree a general purpose mechanism is good, but in this case we
already have "scalar" so why not "list"?

    $count = list getpwnam("tchrist");

While I agree that /l is bad, I think going through the crap of "= () ="
is even worse. Does it work? Yes. But is it easily usable and fun, even
for non-experts? No.

-Nate

Reply via email to