> I think this is definitely something we should do if we want to confuse
> people as much as possible :-)

This is likely true, seeing as I *still* have troubles keeping the various
Lisp eq/eql/equal/equalp's straight. ;)

> I would therefore vote that we keep these opcodes as verbose as
> possible. So no eq/eql/equal, but rather
> same_address/same_content/compare/compare_as_num/compare_as_string.

Some of those are probably a little too verbose for my tastes. ;)

We're already using 'eq' to perform equality testing, and in the interests
of maintaining a consistent design I would choose to stick with something
eq-related as opposed to changing it to 'same'.

eqaddr/eqval?  eq_addr/eq_val?  eq_address/eq_value?

With respects to the compare_as_num/compare_as_string opcodes, there's
also already a 'cmp' opcode and there already seems to be the established
naming scheme of opcodeX, where X is one of n/i/s/p, depending on the type
being dealt with (ie. cleari, clearn, clears, clearp).

cmpi/cmpn/cmps/cmpp?  cmpasi/cmpasn/cmpass/cmpasp?
cmp_as_i/cmp_as_n/cmp_as_s/cmp_as_p?

Personally, I'd probably pick the first option in each of the above sets,
though that is just my preference... :)

Cory

Reply via email to