On 4/19/04 1:30 PM, Larry Wall wrote:
> On Mon, Apr 19, 2004 at 01:14:57PM -0400, John Siracusa wrote:
> : I know we are running out of special characters, but I really, really think
> : that required named parameters are a natural fit for many common APIs.  A12
> : has reinforced that belief.  Save me, Dami-Wan Wallnobi, you're my only
> : hope...
> 
> Well, actually, we saved you last summer when we decided to make +
> mean that the parameter must be named.

...named and required, or named and optional?  IOW, is this all true?

    sub foo(+$a, +$b) { ... }

    foo();          # compile-time error!
    foo(1, 2);      # compile-time error!
    foo(a => 1, 2); # compile-time error!
    foo(a => 1);    # compile-time error!

    foo(a => 5, b => 7); # ok
    foo(b => 1, a => 2); # ok

-John

Reply via email to