> > Having it in the core, in C[++], would be that much more efficient,
> > and that much less of a hack.  Maybe the tradeoff is that it
> > wouldn't work.  :-)
> 
> Everyone's making these assumptions, WHY WON'T ANYONE LOOK AT
> CLASS::OBJECT?!

It might not work, Schwern. And even if it did, it might be really slow.
Somebody should write an implementation first, and then tackle efficiency. 

Something like

  sub sub {
    my ($self, $method_name, $method ) = @_;
    *{ref($self).'::'.$method_name} = $method;
  }

for adding object methods would be a good start. I think I'll call it 
Class::Object.

Dan

Reply via email to