> Oh, one other tweak. The RFC proposes to overload next
> to mean "fall through to the next case". I don't think
> this is wise, since we'll often want to use loop controls
> within a switch statement. Instead, I think we should
> use skip to do that. (To be read as "Skip to the next
> statement.")
I would like to suggest a different keyword that does not imply some
`jumping' action. For years, I have used `nobreak' in my C code when I want
to indicate that a case fall-through is intentional:
#define nobreak
switch(...) {
case 1: ...;
nobreak; /* intentional fall-through */
case 2: ...;
break;
case 3: ...;
}
Does anyone agree that `nobreak' reads much better than `skip'?
Dave.