On Wed, Feb 21, 2007 at 12:49:20AM +0100, Thomas Wittek wrote:
: Larry Wall schrieb:
: > I think the ¥ and Y operators are going to have to change to something else.
: 
: Very probably I missed something as I'm only a distant observer of the
: Perl6 development: Why not just call it "zip"?!
: There is a function called zip, wouldn't it be possible to create an
: operator with the same name?
: 
: zip(@a; @b) -> function
: @a zip @b -> operator
: 
: Or would that lead to grammar ambiguities, that are impossible to resolve?

Hmm, but then what corresponds to XX?  I'd be more inclined to go
the other way and say that you can transform any list infix form to
the corresponding function form:

    @a ZZ @b ZZ @c -> zip operator
    ZZ(@a; @b; @c) -> zip function

    @a XX @b XX @c -> cross operator
    XX(@a; @b; @c) -> cross function

    @a X*X @b X*X @c -> cross product operator
    X*X(@a; @b; @c) -> cross product function

    @a MM @b MM @c -> minmax operator
    MM(@a; @b; @c) -> minmax function

Larry

Reply via email to