Hi Damian,

The .kxxv method name is a placeholder.

The brief discussion that motivated introducing it is at:
http://irclog.perlgeek.de/perl6/2014-04-13#i_8582049

Larry has chimed in at:
http://irclog.perlgeek.de/perl6/2014-04-14#i_8582684

---------------

Another discussion that's unfolding right now and could do with your
attention imo is:
https://github.com/perl6/specs/commit/9213b1382078fee890ab9d74223f3c7e95942837

---------------

All of the above illustrates an issue that we ought to address, namely
where we best discuss this stuff to make the best use of your time:

1. For the last few years almost all discussion is entirely on #perl6.

There's a real time log of this #perl6 discussion (as per the irclog links
above).
(There's also a representative subset of lines I hand select after the fact,
often days later, at eg http://irclog.perlgeek.de/perl6/2014-04-13/summary )

Sometimes there's discussion on #perl6 that involves Larry, followed by
commits that generally stick.

Or there's discussion without Larry followed by commits which are reverted
if he doesn't like it.

Or there's discussion followed by a message asking for Larry's input.
This is done either by just saying so in the log or, more reliably, by
leaving a message with an IRC bot. He will see the message by
A) reading it in the log and/or B) receiving a message from the bot
the next time he says something on #perl6.

Or there's discussion that leads to nothing being decided (but which
can be read later via the logs).

Larry is on #perl6 for at least a while most days including weekends.
Also, he catches up on what has been said by reading the entire backlog
each time he returns. (Almost no regulars use the "summary" I create;
for one thing it's often hours or days behind.)

The above arrangement works for us and $Larry. But I'm thinking we might
want to go back to @Larry with both you and him and figure out how we
make that work for you.

2. Sometimes a discussion arises on github in response to a commit
(eg the discussion that I said above could do with your attention).

Anyone can follow whatever P6 repos they want. They'll then get
emails alerting them to such discussions with a link back to github
comments. We could add you to the github/perl6 org, and maybe others.

3. And then there's these mailing lists. Almost no discussion occurs on
these lists these days. That said, we do respond if someone posts.

------------

It's great to see you back.

Did you see that lizmat has taken a stab at implementing 'is cached' --
because she saw that that's the one unimplemented thing in some code
you recently published?

How confident are you that your all-in-one CS teaching platform concept
will be taken up by some educational institutions? What timeframe are
you thinking is involved here? Are you thinking P6 is already ready for it?

I don't think we're there yet but it seems like the perfect initial goal for
P6-as-a-product.

--
raiph




On Mon, Apr 14, 2014 at 1:03 AM, Damian Conway <dam...@conway.org> wrote:

> >   Spec Bag.kxxv
>
> It's a clever name...but maybe too clever?
>
> I find it unfortunate that a method that only returns keys has a 'v'
> in its name.
> Up to now, we've had a more predictable pattern to naming these accessors.
>
> How about one of:
>
>      .weighted-keys
>      .distribution
>
> instead???
>
> And what is the use-case for this?
> I can see that I might want:
>
>     $bag.kxxv.pick;
>
> but:
>
>     $bag.pick
>
> already does that.
>
> I guess you might want to separate out the steps for some reason:
>
>     my $selection = median_value_from( $bag.kxxv );
>
> but that would be far more readable/maintainable as:
>
>     my $selection = median_value_from( $bag.distribution );
>
>
> Damian
>



-- 
raiph

Reply via email to