Rename log_lock_failure GUC to log_lock_failures for consistency. This commit renames the GUC log_lock_failure to log_lock_failures to align with the existing similar setting log_lock_waits, which uses the plural form. This improves naming consistency across related GUCs.
Suggested-by: Peter Eisentraut <[email protected]> Author: Fujii Masao <[email protected] Reviewed-by: Peter Eisentraut <[email protected]> Discussion: https://postgr.es/m/[email protected] Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/73bdcfab35ec0a7eff1a5dd630cbad8e77054547 Modified Files -------------- doc/src/sgml/config.sgml | 6 +++--- doc/src/sgml/release-18.sgml | 2 +- src/backend/access/heap/heapam.c | 6 +++--- src/backend/access/heap/heapam_handler.c | 2 +- src/backend/storage/lmgr/lock.c | 2 +- src/backend/utils/misc/guc_tables.c | 4 ++-- src/backend/utils/misc/postgresql.conf.sample | 2 +- src/include/storage/lock.h | 2 +- 8 files changed, 13 insertions(+), 13 deletions(-)
