Further cleanup related to statistics import support in postgres_fdw.

* Reorder the conditions in an if-else block for efficiency.
* Reorder struct definitions for readability.
* Reorder arguments for some functions for consistency.
* Move variables to the required scope.
* Rename a variable to match an input argument.
* Add/Tweak some comments/docs for clarity.

Author: Etsuro Fujita <[email protected]>
Reviewed-by: Bharath Rupireddy <[email protected]>
Discussion: 
https://postgr.es/m/CAPmGK14otpa7XZyBO5GxDABUK9OPWFLsAwoQP3ugNdXq%3DK4J1g%40mail.gmail.com
Backpatch-through: 19

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/5c52858ecdc052b2a9fc2a7f30e338ec6777c4ae

Modified Files
--------------
contrib/postgres_fdw/postgres_fdw.c | 136 +++++++++++++++++++-----------------
doc/src/sgml/fdwhandler.sgml        |   2 +-
src/backend/commands/analyze.c      |   5 ++
3 files changed, 76 insertions(+), 67 deletions(-)

Reply via email to