Rename the WAIT FOR command to WAIT in the documentation The command tag is WAIT, but the reference page called the command "WAIT FOR" in its title, index entry, psql help name and throughout its prose, and so did the error messages. FOR is a noise word that makes the grammar read like English, exactly as INTO does for INSERT and FROM does for DELETE; neither of those is part of the command's name. Settle on WAIT everywhere the command is named, and keep WAIT FOR LSN wherever the syntax itself is being shown.
Rename the reference page's id and file name to match, following cb2c696b1dd: v19 is not released, so the URL is not yet baked into a supported version, and every other page's id matches its title. Reported-by: Masahiko Sawada [email protected] Author: Xuneng Zhou [email protected] Reviewed-by: Alexander Korotkov [email protected] Discussion: https://postgr.es/m/CAD21AoBdtiPTbm7T_aNeDON9JpFG9g%3DJDUP4WU-Y8t8_xqvR5Q%40mail.gmail.com Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/a23ab4862cfebb9aba58f713854b7d5e42d5f947 Modified Files -------------- doc/src/sgml/high-availability.sgml | 2 +- doc/src/sgml/ref/allfiles.sgml | 2 +- doc/src/sgml/ref/{wait_for.sgml => wait.sgml} | 30 +++++++++++++-------------- doc/src/sgml/reference.sgml | 2 +- src/backend/commands/wait.c | 8 +++---- src/test/recovery/t/049_wait_for_lsn.pl | 9 ++++---- 6 files changed, 26 insertions(+), 27 deletions(-)
