Re: clog page numbers, as returned by TransactionIdToPage
- int pageno = TransactionIdToPage(xid); /* get
page of parent */
+ int64 pageno = TransactionIdToPage(xid); /* get page of
parent */
...
- int pageno = TransactionIdToPage(subxids[0]);
+ int64 pageno = TransactionIdToPage(subxids[0]);
int offset = 0;
int i = 0;
...
- int nextpageno;
+ int64 nextpageno;
Etc.
In all those places where you are replacing int with int64 for the kind of
values returned by TransactionIdToPage(), would you mind replacing the int64's
with a type name, such as ClogPageNumber, for improved code maintainability?