On 10.03.23 01:03, Nathan Bossart wrote:
By the way, I'm not sure what the separation between 0001 and 0002 is
supposed to be.
I'll combine them. I first started with user.c only, but we kept finding
new messages to improve.
I combined the patches in v7.
I have committed two pieces that were not message changes separately.
I think the following change in DropRole() is incorrect:
if (!is_admin_of_role(GetUserId(), roleid))
ereport(ERROR,
(errcode(ERRCODE_INSUFFICIENT_PRIVILEGE),
- errmsg("must have admin option on role \"%s\"",
- role)));
+ errmsg("permission denied to drop role"),
+ errdetail("Only roles with the %s attribute and the
%s option on role \"%s\" may drop this role.",
+ "CREATEROLE", "ADMIN",
NameStr(roleform->rolname))));
The message does not reflect what check is actually performed. (Perhaps
this was confused with a similar but not exactly the same check in
RenameRole().)
That was the only "factual" error that I found.
In file_fdw_validator(), the option names "filename" and "program" could
be parameterized.
In DropOwnedObjects() and ReassignOwnedObjects(), I suggest the
following changes, for clarity:
- errdetail("Only roles with privileges of role \"%s\" may drop its
objects.",
+ errdetail("Only roles with privileges of role \"%s\" may drop objects
owned by it.",
- errdetail("Only roles with privileges of role \"%s\" may reassign its
objects.",
+ errdetail("Only roles with privileges of role \"%s\" may reassign
objects owned by it.",
The rest looks okay to me.