> On 14 Sep 2023, at 08:28, Krishnakumar R <kksrcv...@gmail.com> wrote:

> Please find a small patch to improve code readability by modifying
> variable name to reflect the logic involved - finding diff between end
> and start time of WAL sync.

-       INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, duration, start);
+       INSTR_TIME_SET_CURRENT(end);
+       INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, end, start);

Agreed, the duration is the result of the INSTR_TIME_ACCUM_DIFF calculation,
not what's stored in the instr_time variable.

--
Daniel Gustafsson



Reply via email to