> If you can find a good way to do it without convoluting the testfile which > currently just does a skip_all in case of LibreSSL, then why not. If it > reduce > readability of the test file then it's probably not worth it since it's not > using any different codepaths from the OpenSSL counterpart.
Done. I added an if with an early exit instead of the skip, it seems to work properly with a local LibreSSL build I tested and I think it looks okay. > It also makes more sense to me to first test parsing, and then > parsing+loading. Also done. I also modified the test to use a connection string so that I don't have to add a trust entry to pg_hba before the connection tests.
v3-0001-Add-pg_hosts_file_rules-to-inspect-the-hosts-conf.patch
Description: Binary data
