> > Fewer parentheses are generally more readable, IMHO. > So https://wiki.postgresql.org/wiki/The_PostgreSQL_C_Dialect > > ereport(ERROR, > (errcode(ERRCODE_DIVISION_BY_ZERO), > errmsg("division by zero"))); > > can be replaced by > > ereport(ERROR, > errcode(ERRCODE_DIVISION_BY_ZERO), > errmsg("division by zero")); > > ```` >
I just saw this, and I had already a change a while back. Per e3a87b4991cc2d00, fewer parens is the standard for new code, but existing code is not altered to avoid code churn and messy backports.
