On Sat, Jul 25, 2026 at 1:48 AM Yugo Nagata <[email protected]> wrote:
> I've attached the v12 patch, which incorporates Kato-san's feedback.
>
> Regarding the column names, I noticed the change from skipped_* to
> lock_skipped_*.
> While I initially preferred skipped_*, I understand Kato-san's point
> considering
> that there could be other reasons for skipping in the future.
Thank you!
> > > +{ oid => '8142', descr => 'statistics: last skipped vacuum time for a
> > > table',
> > > + proname => 'pg_stat_get_last_lock_skipped_vacuum_time', provolatile =>
> > > 's',
> >
> > The proname now says lock_skipped, but the descr still says just
> > "skipped". I think the descr should mention the lock cause as well,
> > and the same applies to the other seven entries.
>
> I changed them like:
>
> 'statistics: last vacuum skip time due to lock unavailability for a table'
> 'statistics: number of vacuum skips due to lock unavailability for a table'
>
> How do these sound?
These are well to me. One small thing about the analyze count entries:
> +{ oid => '8148', descr => 'statistics: number of analyzes skips due to lock
> unavailability for a table',
"analyzes skips" doubles the plural. Since "skips" is the noun here, I
think "analyze skips" is better, matching "vacuum skips" in 8146. The
same applies to 8149.
--
Best regards,
Shinya Kato
NTT OSS Center