Hi all, On Mon, Aug 3, 2026 at 5:44 AM Scott Ray <[email protected]> wrote: > > I rebased on 4e68b7e291d. Upstream took TAP 055, so the new TAP is now 056. >
Thank you for addressing my suggestion. And thank you for the updated patch. I reviewed and tested the v3 patch, including the newly added datname column. The patch applied cleanly and built successfully on my tree and verified that the datname column is now included in the pg_xmin_horizon view definition and is correctly populated for backend and prepared transaction entries. The reported values were consistent with the corresponding database information, and the addition improves the readability of the view by avoiding an extra join to pg_database. The new column also aligns well with the existing interfaces provided by pg_stat_activity, pg_replication_slots, and pg_prepared_xacts. The updated patch looks good to me. Regards, Solai
