> On Aug 13, 2026, at 11:39, Japin Li <[email protected]> wrote:
> 
> Hi Chao,
> 
> Thanks for updating the patch.

Hi Jipan, thanks a lot for reviewing.

> 
> Date: Thu, 13 Aug 2026 11:32:59 +0800
> 
> On Thu, 13 Aug 2026 at 09:47, Chao Li <[email protected]> wrote:
>>> On Aug 13, 2026, at 05:56, Zsolt Parragi <[email protected]> wrote:
>>> 
>>> I have two minor comment for v5, otherwise it looks good to me:
>> 
>> Hi Zsolt,
>> 
>> Thanks a lot for reviewing.
>> 
>>> 
>>> +typedef enum
>>> +{
>>> + STREAM_NEW,
>>> + STREAM_HAS_DATA,
>>> + STREAM_FINISHED,
>>> +} pg_stream_state;
>>> +
>>> 
>>> This is duplicated in two files, wouldn't be astreamer.h a better place for 
>>> it?
>> 
>> I think this makes sense. Plus your second comment, this enum can be shared 
>> by all 3 astreamers. I moved it to astreamer.h and renamed it to 
>> astreamer_decompression_state.
>> 
> 
> The astreamer_decompression_state should be added to pgindent's typedefs.list.

Yes, I missed that part.

PFA v7: addressed Jipan’s comment.

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/




Attachment: v7-0001-Fix-detection-of-truncated-compressed-backups.patch
Description: Binary data

Reply via email to