On Fri, Sep 4, 2026 at 7:42 AM Zhijie Hou (Fujitsu) <[email protected]> wrote: > > On Thursday, September 3, 2026 9:57 PM shveta malik <[email protected]> > wrote: > > > > The patch 001 looks good to me. I had just one comment which I noticed > > Kuroda-San has already covered. > > Thanks for the comments. > > > > > ReplicationSlotMarkDirty(); > > ReplicationSlotSave(); > > These calls are only needed if xmin is adjusted. > > Changed. > > > -- > > > > Now, the better names for 'init_conflict_slot_xmin' could be: > > adjust_conflict_slot_xmin, refresh_conflict_slot_xmin. > > > > I chose Kuroda-San's version in this version. > > > -- > > > > Also would it be better if we change elog to: > > > > if (!TransactionIdIsValid(old_xmin)) > > elog(DEBUG1, "initialized conflict detection slot's xmin to %u", > > xmin_horizon); > > else elog(DEBUG1, "adjusted conflict detection slot's xmin from %u to %u", > > old_xmin, xmin_horizon); > > I added a single elog(DEBUG without an if condition to keep it simple. > Users can already see the history from the log anyway. > > Apart from above comments, I also addressed comments from Kuroda-San[1] and > Nisha[2]. > > [1] > https://www.postgresql.org/message-id/OS9PR01MB1214975F154718013E1B82D4AF5B62%40OS9PR01MB12149.jpnprd01.prod.outlook.com > [2] > https://www.postgresql.org/message-id/CABdArM7nwKpoVQ5v42xz6D-qAVrNGdb%2ByMUGmSR8Tapv%3DmFzDw%40mail.gmail.com >
I have no further comments on the patch. thanks Shveta
