On February 4, 2019 6:43:44 AM GMT+01:00, Michael Paquier <mich...@paquier.xyz> 
wrote:
>On Sun, Feb 03, 2019 at 10:58:02PM +1100, Thomas Munro wrote:
>> If there are no objections, I'm planning to do a round of testing and
>> commit this shortly.
>
>Hm.  That looks sane to me at quick glance.  I am a bit on the edge
>regaring the naming "FullTransactionId", which is actually a 64-bit
>value with a 32-bit XID and a 32-bit epoch.  Something like
>TransactionIdWithEpoch or EpochTransactionId sounds a bit better to
>me.  My point is that "Full" is too generic for that.

I'm not a fan of names with epoch in it - these are the real transaction IDs 
now. Conflating them with the until-now inferred epochs sounds like a bad idea 
to me. We IMO should just treat the new type as a 64bit uint, and the 32bit as 
a truncated version. Like, we could just add 64 as a prefix.

Andres
-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply via email to