On Fri, 14 Jun 2019 at 05:22, Tom Lane <[email protected]> wrote: > > Robert Haas <[email protected]> writes: > > So I think that this should probably be changed to say something like > > "Improve optimization of self-joins on ctid columns" or "Improve > > optimization of joins involving columns of type tid." > > The latter seems fine to me.
The latter seems a bit inaccurate to me given the fact that a column with the type tid could exist elsewhere in the table. Perhaps "columns of type tid" can be swapped with "a table's ctid column". -- David Rowley http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services
