From: Jamison, Kirk/ジャミソン カーク <k.jami...@fujitsu.com>
> I also did not remove the duplicate code from smgrnblocks because Amit-san
> mentioned that when the caching for non-recovery cases is implemented, we
> can use it for non-recovery cases as well.

But the extra code is not used now.  The code for future usage should be added 
when it becomes necessary.  Duplicate code may make people think that you 
should add an argument to smgrnblocks() instead of adding a new function.

+               if (reln->smgr_cached_nblocks[forknum] != InvalidBlockNumber)
+                       return reln->smgr_cached_nblocks[forknum];
+               else
+                       return InvalidBlockNumber;

Anyway, the else block is redundant, as the variable contains 
InvalidBlockNumber.

Also, as Amit-san mentioned, the cause of the slight performance regression 
when shared_buffers is small needs to be investigated and addressed.  I think 
you can do it after sharing the performance result with a large shared_buffers.

I found no other problem.


Regards
Takayuki Tsunakawa

Reply via email to