Peter Eisentraut <pete...@gmx.net> writes: > Here is the patch that adds [RESTRICT|CASCADE] to ALTER TYPE ... > ADD/ALTER/DROP/RENAME ATTRIBUTE, so that recurses to typed tables.
And here's my commitfest review of it: - patch applies cleanly - adds regression tests - passes them - is useful and needed, and something we don't already have - don't generate warnings (or I missed them) :) Code wise, though, I wonder about the name of the "recursing" parameter of the renameatt_internal function is src/backend/commands/tablecmds.c, which seems to only get used to detect erroneous attempt at renaming the table column directly. Maybe it's only me not used enough to PostgreSQL code yet, but here it distract the code reader. Having another parameter called "recurse" is not helping, too, but I don't see this one needs to be changed. I'm not sure what a good name would be here, alter_type_cascade is an example that comes to mind, on the verbose side. As I think the issue is to be decided by a commiter, I will go and mark this patch as ready for commiter! Regards, -- Dimitri Fontaine http://2ndQuadrant.fr PostgreSQL : Expertise, Formation et Support -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers