On Fri, Mar 23, 2012 at 18:05, Fujii Masao <[email protected]> wrote: > On Sat, Mar 24, 2012 at 1:49 AM, Robert Haas <[email protected]> wrote: >> On Fri, Mar 23, 2012 at 12:42 PM, Fujii Masao <[email protected]> wrote: >>> On Fri, Mar 23, 2012 at 9:41 PM, Robert Haas <[email protected]> wrote: >>>> On Fri, Mar 23, 2012 at 6:13 AM, Fujii Masao <[email protected]> wrote: >>>>> On Fri, Mar 23, 2012 at 5:56 PM, Magnus Hagander <[email protected]> >>>>> wrote: >>>>>> Might it be a good idea to put it on it's own row instead of changing >>>>>> the format of an existing row, in order not to break scripts and >>>>>> programs that are parsing the previous output? >>>>> >>>>> Good idea! What row name should we use for the WAL file containing >>>>> REDO record? "Latest checkpoint's REDO file"? >>>> >>>> Sounds good to me. I like the idea, too. The status quo is an >>>> unnecessary nuisance, so this will be a nice usability improvement. >>> >>> Attached patch adds new row "Latest checkpoint's REDO WAL segment:" into >>> the result of pg_controldata. I used the term "WAL segment" for the row name >>> instead of "file" because "WAL segment" is used in another row "Bytes per >>> WAL >>> segment:". But better name? >> >> s/segment/file/g? > > Yep, "file" might be more intuitive for a user than "segment". Attached is the > "file" version of the patch.
We're already using "file" to mean something different *internally*, don't we? And since pg_controldata shows fairly internal information, I'm not sure this is the best idea. Maybe compromise and call it "segment file" - that is both easier to understand than segment, and not actually using a term that means something else... -- Magnus Hagander Me: http://www.hagander.net/ Work: http://www.redpill-linpro.com/ -- Sent via pgsql-hackers mailing list ([email protected]) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers
