Andrew Dunstan <and...@dunslane.net> writes:
> This time with a patch.

Nitpicky gripe: "fix_path" is a mighty generic name.  How about
"fix_path_for_windows" or something like that?  I don't think I'd
mark it inline, either.

More generally, the behavior of combining two (maybe) filename segments
seems overcomplicated and unnecessary.  Why not just have it take *one*
argument and back-slashify that, without the concatenation behavior?
Then you'd have two calls instead of one at some of the call sites,
but that doesn't seem like much of a loss.  The malloc'd strings are
getting leaked anyway.  The function itself would reduce to pg_strdup
and a backslashification loop.  Also, you could turn it into a complete
no-op (not even pg_strdup) on non-Windows.

                        regards, tom lane


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to