While looking around to fix the pg_malloc(0) issue, I noticed that
various other pieces of code such as pg_basebackup have essentially
identical functions, except they're called xmalloc().  I propose to
standardize all these things on this set of names:

        pg_malloc
        pg_malloc0      (for malloc-and-zero behavior)
        pg_calloc       (randomly different API for pg_malloc0)
        pg_realloc
        pg_free
        pg_strdup

Any objections?

                        regards, tom lane


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to