Hi,

Attached is an updated patch that uses better schema / role names.

--
Robins Tharakan

On 18 March 2013 12:59, robins <thara...@gmail.com> wrote:

> Thanks Alvaro.
>
> Since the tests were running fine, I didn't bother with elaborate names,
> but since you're concerned guess I'll make that change and re-submit.
>
> And yes, I've already submitted (to Commitfest) another patch related to
> regression tests for SEQUENCE.
> Would submit the SCHEMA patch once the above change is done.
> --
> Robins
>
>
> On 18 March 2013 09:42, Alvaro Herrera <alvhe...@2ndquadrant.com> wrote:
>
>> robins escribió:
>> > Hi,
>> >
>> > Please find attached a patch to take 'make check' code-coverage of
>> SCHEMA
>> > from 33% to 98%.
>> >
>> > Any feedback is more than welcome.
>>
>> I think you should use more explicit names for shared objects such as
>> roles -- i.e. not "r1" but "regression_user_1" and so on. (But be
>> careful about role names used by other tests).  The issue is that these
>> tests might be run in a database that contains other stuff; certainly we
>> don't want to drop or otherwise affect previously existing roles.
>>
>> > p.s.: I am currently working on more regression tests (USER / VIEW /
>> > DISCARD etc). Please let me know if I need to post these as one large
>> > patch, instead of submitting one patch at a time.
>>
>> I think separate patches is better.  Are you adding these patches to the
>> upcoming commitfest, for evaluation?  https://commitfest.postgresql.org
>>
>> --
>> Álvaro Herrera                http://www.2ndQuadrant.com/
>> PostgreSQL Development, 24x7 Support, Training & Services
>>
>
>

Attachment: regress_schema_v2.patch
Description: Binary data

-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to