On Jun 12, 2013, at 8:00 PM, Brendan Jurd <[email protected]> wrote:
> array_dims - Returns the dimensions of the array, unless it is empty
> in which case NULL.
> array_proper_dims - Returns the dimensions of the array.
> array_ndims - Returns the number of dimension, unless it is empty in
> which case NULL.
> array_proper_ndims - Returns the number of dimensions.
>
> ... and so on for _length, _upper and _lower.
Similar things should have dissimilar names. I propose:
<bikeshedding>
Old | New
--------------+--------------
array_dims | array_desc
array_ndims | array_depth
array_length | array_size
array_lower | array_start
array_upper | array_finish
The last two are meh, but it’s a place to start…
</bikeshedding>
David
--
Sent via pgsql-hackers mailing list ([email protected])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers