On 02/26/2014 06:13 PM, Alvaro Herrera wrote:

There's one thing that rubs me the wrong way about all this
functionality, which is that we've named it "huge TLB pages".  That is
wrong -- the TLB pages are not huge.  In fact, as far as I understand,
the TLB doesn't have pages at all.  It's the pages that are huge, but
those pages are not TLB pages, they are just memory pages.

I think we have named it this way only because Linux for some reason
named the mmap() flag MAP_HUGETLB for some reason.  The TLB is not huge
either (in fact you can't alter the size of the TLB at all; it's a
hardware thing.) I think this flag means "use the TLB entries reserved
for huge pages for the memory I'm requesting".

Since we haven't released any of this, should we discuss renaming it to
just "huge pages"?

Linux calls it "huge tlb pages" in many places, not just MAP_HUGETLB. Like in CONFIG_HUGETLB_PAGES and hugetlbfs. I agree it's a bit weird. Linux also calls it just "huge pages" in many other places, like in /proc/meminfo output.

FreeBSD calls them superpages and Windows calls them "large pages". Yeah, it would seem better to call them just "huge pages", so that it's more reminiscent of those names, if we ever implement support for super/huge/large pages on other platforms.

- Heikki


--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to