On Thu, Mar 12, 2015 at 8:43 PM, Stas Kelvich <stas.kelv...@gmail.com>
wrote:

> Documentation along with style fix.
>

Since we change the interface of extension we have to change it version and
create a migration script.
E.g. you have to rename cube--1.0.sql to cube--1.1.sql and create
cube--1.0--1.1.sql to migrate the old version.

+ -- Alias for backword compatibility
  CREATE FUNCTION cube_distance(cube, cube)
  RETURNS float8
+ AS 'MODULE_PATHNAME', 'distance_euclid'
+ LANGUAGE C IMMUTABLE STRICT;

For backward compatibility it would be better to keep the old name of
cube_distance so that extension with old definition could work with new
binary.

------
With best regards,
Alexander Korotkov.

Reply via email to