On 2015-08-12 18:52:59 -0400, Tom Lane wrote:
> Andres Freund <and...@anarazel.de> writes:
> > I went through all headers in src/include and checked for macros
> > containing [^&]&[^&] and checked whether they have this hazard. Found a
> > fair number.
> 
> > That patch also changes !! tests into != 0 style.
> 
> Looks OK to me, except I wonder why you did this
>  
>  #define TRIGGER_FIRED_FOR_ROW(event) \
> -     ((event) & TRIGGER_EVENT_ROW)
> +     (((event) & TRIGGER_EVENT_ROW) == TRIGGER_EVENT_ROW)
> 
> rather than != 0.  That way doesn't look either more efficient or
> more readable.

Purely consistency with the surrounding code. I was on the fence about
that one...


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to