Accepted and committed as alpha: 1.13 in
http://squeaksource.com/PharoGoodies/

modified api is:

newBldr := XMLBuilder new.
newBldr xmlPreprocessor; attributes: #(‘a=”6″‘ ‘b=”7″‘);
  test: ‘welcome to builders’
  with: [ newBldr attributes: #('a="1"' 'b="2"'); trial: '';
                 attributes: #('a="3"' 'b="4"'); trial: 'testing..' ;
                 trial ].

to get:

'<?xml version="1.0" ?><test a="6"  b="7" >welcome to builders<trial a="1"
b="2" ></trial><trial a="3"  b="4" >testing..</trial><trial></trial></test>'


hope this aligns.. lots more stil to be cleaned for plugins, will do so by
the next commit..

-Skrish
*****

There is an interest! Please submit/publish it...
Now What is the exact API I found cNode: a bit a bad name. What does
it mesn childrenNode:


newBldr := XMLBuilder new xmlPreprocessor.
newBldr mbAttr: #(‘a=”6″‘ ‘b=”7″‘); test: ‘welcome to builders’

why new and xmlPreprocessor

mbAttr: sucks also!

Could you shine a bit the API to be reader friendly?


Stef
_______________________________________________
Pharo-project mailing list
Pharo-project@lists.gforge.inria.fr
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project

Reply via email to