On Sun, 8 Sep 2002, Yasuo Ohgaki wrote:

> yohgaki               Sun Sep  8 18:38:57 2002 EDT
> 
>   Modified files:              
>     /php4     CODING_STANDARDS 
>   Log:
>   It seems we're better to mention about missing functions.
>   PHP_FUNCTION -> ZEND_FUNCTION

erm, where was this decided? The whole source uses PHP_FUNCTION...

[derick@kossu php-4.3.0dev]$ grep -r PHP_FUNCTION * | wc -l
   5990

[derick@kossu php-4.3.0dev]$ grep -r ZEND_FUNCTION * | wc -l
    217

So I'd rather see those other functions converted to PHP_FUNCTION 
(execpt the zend builtin stuff of course).

Derick



>   
>   
> Index: php4/CODING_STANDARDS
> diff -u php4/CODING_STANDARDS:1.18 php4/CODING_STANDARDS:1.19
> --- php4/CODING_STANDARDS:1.18        Thu Aug 22 10:04:01 2002
> +++ php4/CODING_STANDARDS     Sun Sep  8 18:38:57 2002
> @@ -115,11 +115,15 @@
>      cvs user foo.  This allows easier tracking of why code was commented out, 
>      especially in bundled libraries.  
>  
> +[10] Do no define that is not available. For instance, if library available is 
> +     missing function(s), do not define function nor raise error for missing 
> +     function(s).
> +
>  Naming Conventions
>  ------------------
>  
>  [1] Function names for user-level functions should be enclosed with in
> -    the PHP_FUNCTION() macro. They should be in lowercase, with words
> +    the ZEND_FUNCTION() macro. They should be in lowercase, with words
>      underscore delimited, with care taken to minimize the letter count.
>      Abbreviations should not be used when they greatly decrease the
>      readability of the function name itself.
> @@ -220,7 +224,7 @@
>  
>  /* {{{ proto int abs(int number)
>     Returns the absolute value of the number */
> -PHP_FUNCTION(abs)
> +ZEND_FUNCTION(abs)
>  {
>     ...
>  }
> 
> 
> 
> -- 
> PHP CVS Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
> 

---------------------------------------------------------------------------
 Did I help you?   http://www.derickrethans.nl/link.php?url=giftlist
 Frequent ranting: http://www.derickrethans.nl/
---------------------------------------------------------------------------
                 PHP: Scripting the Web - [EMAIL PROTECTED]
                    All your branches are belong to me!
                SRM: Script Running Machine - www.vl-srm.net
---------------------------------------------------------------------------


-- 
PHP CVS Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to