--On Monday, November 11, 2002 11:20 PM +0200 Andi Gutmans <[EMAIL PROTECTED]> wrote:

At 10:22 PM 11/11/2002 +0100, Derick Rethans wrote:
On Mon, 11 Nov 2002, Harrie Hazewinkel wrote:

> harrie                Mon Nov 11 16:09:19 2002 EDT
>
>   Modified files:
>     /php4/ext/snmp    CREDITS php_snmp.h snmp.c
>   Log:
>   Adding SNMPv3 support.

@@ -113,6 +121,11 @@
        PHP_FE(snmp_get_quick_print, NULL)
        PHP_FE(snmp_set_quick_print, NULL)
        PHP_FE(snmpset, NULL)
+       PHP_FE(snmpv3get, NULL)
+       PHP_FE(snmpv3walk, NULL)
+       PHP_FE(snmpv3realwalk, NULL)
+       PHP_FALIAS(snmpv3walkoid, snmpv3realwalk, NULL)
+       PHP_FE(snmpv3set, NULL)
        {NULL,NULL,NULL}

These function names don't follow the PHP standards, I think we should
definitely come up with better names.
I agree. what's wrong with snmp_get, snmp_walk, and so on?
I believe it is neccessary to have the 'v3' in the name. It makes very clear
to people that it is for snmpv3 and not any opther snmp version.

SNMPv3 is the protocol version that has security support and is known
as under SNMPv3 by many people.


Anyway, where would be the function name guide lines on the website.
I cannot find it and a pointer would be appreciated.

Cheers,


Harrie

Internet Management Consulting
mailto: [EMAIL PROTECTED]                   http://www.lisanza.net/
--------------------------------------------------------------------
Author of MOD-SNMP, enabling SNMP management the Apache HTTP server

--
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to