Well, if you're doing that, go ahead and change stristr() and strstr()
too... And eregi() and ereg()... It should be done one way or another.
Besides, wasn't one of the points in introducing this function that so many
users were looking for it?

"Jon Parise" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote:
>
> > You're not the first to voice this opinion.  *I* feel str_ireplace is
better
> > as it follows the naming convention of <module>_<function>.  Others feel
> > stri_replace is better as that follows eregi_replace's style.  I have no
> > trouble going with whatever the majority feels is best.
>
> Get rid of stri_replace() and/or str_ireplace() and just add a fourth
> optional parameter to str_replace() to control case-sensitivity.
>
> --
> Jon Parise ([EMAIL PROTECTED]) :: The PHP Project (http://www.php.net/)



-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to