On 12/07/2016 15:33, Woody Gilk wrote:

The term "frame" comes from Anthony Farrera:
http://blog.ircmaxell.com/2016/05/all-about-middleware.html
<http://blog.ircmaxell.com/2016/05/all-about-middleware.html?m=1>

It refers to moving from one middleware frame to another.

Do you have any suggestions for a better name?

Chain?

function __invoke(Request $req, Chain $chain) {
 $res = $chain->next();
 return $this->doSomething($req, $res);
}

I think it's a bit more intuitive than $frame. You know you are executing the next() function in the Chain of middlewares.

Bye.


--
You received this message because you are subscribed to the Google Groups "PHP 
Framework Interoperability Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to php-fig+unsubscr...@googlegroups.com.
To post to this group, send email to php-fig@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/php-fig/3b48dcd5-f4c5-cf83-997b-3ba83c7effde%40amiran.it.
For more options, visit https://groups.google.com/d/optout.

Reply via email to