Hi Alex, I know I (ab)use 'fill' / 'macro' too much in my code, but I often want to insert (not splice) the result of some calculation. Would you consider a new '_' syntax within 'fill' forms?
: (fill (1 2 _ (+ 1 2)) -> (1 2 3) This can currently be accomplished a few different ways : (let X (+ 1 2) (fill (1 2 X) 'X)) : (let @X (+ 1 2) (macro (1 2 @X))) : (fill (1 2 ^ (list (+ 1 2))) The first two are quite verbose for what is usually a simple or concisely expressed calculation. The last one is ugly. Thoughts? -Erik