[ 
https://issues.apache.org/jira/browse/PIG-802?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12711769#action_12711769
 ] 

Pradeep Kamath commented on PIG-802:
------------------------------------

Review comments:
In MRCompiler, does POPackageLite need to be used in the following too:
{noformat}
if (limit!=-1) {
             POPackage pkg_c = new POPackage(new 
OperatorKey(scope,nig.getNextNodeId(scope)));
...
}
{noformat}

In POPackage, the following declarations :
{noformat}
Iterator<NullableTuple> tupIter; 

Object key; 
{noformat}
should have "protected" access specifier to make the intent that these are used 
in POPackageLite explicit.

In ReadOnceBag.equals() you could also check if the keyInfo maps are equal.

The getValueTuple() in ReadOnceBag had duplicate code from 
POPackage.getValueTuple(). Instead of having the same code in two places, I am 
wondering if you could just construct ReadOnceBag with a POPackageLite instance 
passed in the constructor. Then if you make the POPackageLite.getValueTuple() 
method public, you can just invoke it from ReadOnceBag code. This way the code 
remains in one place. 

> PERFORMANCE: not creating bags for ORDER BY
> -------------------------------------------
>
>                 Key: PIG-802
>                 URL: https://issues.apache.org/jira/browse/PIG-802
>             Project: Pig
>          Issue Type: Improvement
>    Affects Versions: 0.2.0
>            Reporter: Olga Natkovich
>         Attachments: OrderByOptimization.patch
>
>
> Order by should be changed to not use POPackage to put all of the tuples in a 
> bag on the reduce side, as the bag is just immediately flattened. It can 
> instead work like join does for the last input in the join. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to