[ 
https://issues.apache.org/jira/browse/PIG-796?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12715325#action_12715325
 ] 

Pradeep Kamath commented on PIG-796:
------------------------------------

A few comments:
- In TestPOCast.java the variables can be named as something like 
"opWithInputTypeAsByteArray" for the POCast objects since the intent is not so 
clear with the current names
- In POCast.java you can check for the realType inside the catch clause rather 
than before trying to cast to ByteArray. This way, if the cast to ByteArray is 
always successful, we will not be incurring the overhead of the 
if(realType==null) check
- In POCast.java, you can avoid catching ExecException and checking for 
errorCode == 1071. Since the getNext() call in POCast already throws 
ExecException, you can just let ExecExceptions from DataType.toXXX() methods 
bubble out.

> support  conversion from numeric types to chararray
> ---------------------------------------------------
>
>                 Key: PIG-796
>                 URL: https://issues.apache.org/jira/browse/PIG-796
>             Project: Pig
>          Issue Type: Improvement
>    Affects Versions: 0.2.0
>            Reporter: Olga Natkovich
>         Attachments: 796.patch, pig-796.patch
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to