broulik added a comment.

  +1

INLINE COMMENTS

> vaultsmodel.h:36
>      Q_PROPERTY(bool hasError READ hasError NOTIFY hasErrorChanged)
> +    Q_PROPERTY(int rowCount READ rowCount NOTIFY rowCountChanged)
>  

The property name should stay `count` to avoid conflict with `rowCount` which 
us invokable

> vaultsmodel.h:45
>  
> -    int rowCount(const QModelIndex &parent) const override;
> +    int rowCount(const QModelIndex &parent=QModelIndex()) const override;
>  

Coding style

> vaultsmodel.h:96
>      void hasErrorChanged(bool hasError);
> +    void rowCountChanged(int count);
>  

Imho this argument isn't necessary but it's probably consistent with the rest

REPOSITORY
  R845 Plasma Vault

REVISION DETAIL
  https://phabricator.kde.org/D26447

To: ngraham, broulik, ivan, #plasma, #vdg
Cc: plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, zachus, fbampaloukas, 
GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to