ngraham added a comment.

  This should probably be two patches at this point: one to increase the 
spacing when using tablet mode (which IMO is an uncontroversial no-brainer) and 
another to increase the spacing when in desktop mode.

INLINE COMMENTS

> main.qml:45
> +    // If Kirigami.Settings.tabletMode is true, double the amount of space 
> added around the tray icons to make them easier to tap on
> +    readonly property int itemSize: 
> units.roundToIconSize(Math.min(Math.min(width, height), 
> units.iconSizes[iconSizes[Math.min(iconSizes.length-1, iconSize)]])) + 
> (Kirigami.Settings.tabletMode ? Math.round(units.smallSpacing) : 
> Math.round(units.smallSpacing/2))
>      property int hiddenItemSize: units.iconSizes.smallMedium

This should probably be rewritten as an inline function as it's now very 
difficult to read. e.g.:

  readonly property int itemSize {
      if (Kirigami.Settings.tabletMode) {
          return foo;
      } else {
          [put other logic here etc]
          return bar;
      }
  }

REPOSITORY
  R120 Plasma Workspace

REVISION DETAIL
  https://phabricator.kde.org/D27438

To: The-Feren-OS-Dev, #vdg, ngraham, davidre
Cc: broulik, kmaterka, filipf, ndavis, anthonyfieroni, davidre, ngraham, 
plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, 
fbampaloukas, GB_2, ragreen, ZrenBot, alexeymin, himcesjf, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to