davidedmundson added inline comments.

INLINE COMMENTS

> tasksmodel.cpp:544
> +
> +                         if (i < insertPos) {
> +                             --insertPos;

Sure this logic is the right way round?

(I'm not convinced it's wrong either, I'm just confused)

at the start of the function:

insertPos is the right most launcher
we iterate i from 0 to size getting from concatProxy
if we find a window we move it to be next to the launcher, potentially

1. Should that not be  if (i > insertPos) ++insertPos
2. we don't want to increment i if we've moved something to be below i, as we'd 
miss an item.

Might be better to iterate i backwards like hte other loop.

REPOSITORY
  rPLASMAWORKSPACE Plasma Workspace

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D1895

EMAIL PREFERENCES
  https://phabricator.kde.org/settings/panel/emailpreferences/

To: hein, davidedmundson, mart
Cc: plasma-devel, jensreuterberg, sebas
_______________________________________________
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel

Reply via email to