On Thu, Jan 14, 2021 at 08:51:10AM +0100, Giovanni Bechis wrote:
> On Thu, Jan 14, 2021 at 08:46:26AM +0100, Giovanni Bechis wrote:
> > Hi,
> > on current (packages as of today) Puppet cannot start anymore,
> > the error is the following:
> > 
> > [~]$ doas puppet agent -t
> > /usr/local/lib/ruby/site_ruby/2.7/puppet/util.rb:461: warning: URI.escape 
> > is obsolete
> > cannot load such file -- sync
> > 
> > Is this a known issue ?
> > Before updating I was running 6.8 so I do not know when it broke.
> > 
> It seems the sync gem should be ported, maybe other ports could be also 
> affected.
> https://bugs.archlinux.org/task/65107
That issue describes Puppet 6 with Ruby 2.7 which does work fine for me:

        $ pkg_info -m | grep -e ruby -e puppet
        puppet-6.19.1p1     centralised configuration management for networks
        ruby-2.7.2p2        object oriented script language with threads

        $ puppet --version
        6.19.1

Reply via email to