On 30/05/2024 00:04, Stuart Henderson wrote:
> On 2024/05/29 20:11, Fabien ROMANO wrote:
>> By curiosity, lang/lua (5.1.5) doesn't USE_NOBTCFI, there is no JIT ?
>> Why its required for minetest (lua 5.1.4), some patches they bring ?
> 
> This diff changes minetest from using lua (no jit, works on most
> archs) to luajit (restricted archs and doesn't do BTCFI landing pads
> yet). (It could alternatively pull in bsd.port.arch.mk and test
> ${PROPERTIES:Mluajit} to decide which to use).

Haaa ok, thx for explanation, thus the port needs either.

ONLY_FOR_ARCHS = aarch64 arm amd64 i386 powerpc

Or something like this.

.include <bsd.port.arch.mk>
.if ${PROPERTIES:Mluajit}
LIB_DEPENDS+=   lang/luajit
WANTLIB+=       luajit-5.1
USE_NOBTCFI=    Yes
.else
CONFIGURE_ARGS+= -DENABLE_LUAJIT=FALSE
.endif

> 
>> DIST_TUPLE are pretty cool.
> 
> Would be even cooler if people didn't rely on inconsistent automated
> git-archive production on websites and distributed fixed tarballs
> instead.
> 

I have issues with googlesource, I understand your point. Github use a big cache
to avoid generating new tarballs or they just care about timestamp ? Crazy but
handy CI/testing (not for releases, I agree !).

Still the DIST_TUPLE syntax/implementation is uber cool.

This port is using a release, not a commit id, which is a fixed tarballs from
github, this is perfectly fine ?

Otherwise I would prefer to keep $*_V in the port, maybe just bikesheding but
looks cleaner to me.

V =             5.8.0
GAME_V =        5.8.0
IRRLICHTMT_V =  1.9.0mt13
DIST_TUPLE +=   github minetest minetest ${V} .
DIST_TUPLE +=   github minetest minetest_game ${GAME_V} games/minetest_game
DIST_TUPLE +=   github minetest irrlicht ${IRRLICHTMT_V} lib/irrlichtmt

> ===>  Building package for minetest-5.8.0
> Create /usr/ports/packages/amd64/all/minetest-5.8.0.tgz
> Creating package minetest-5.8.0
> /home/_pobj/minetest-5.8.0/fake-amd64/usr/local/man/man6/minetestserver.6: 
> Cannot find NAME section
> /home/_pobj/minetest-5.8.0/fake-amd64/usr/local/man/man6/minetestserver.6: No 
> one-line description, using filename "minetestserver"
> Link to /usr/ports/packages/amd64/ftp/minetest-5.8.0.tgz

cat /usr/ports/pobj/minetest-5.8.0/minetest-5.8.0/doc/minetestserver.6

.so man6/minetest.6

I guess this is not the way to point 'man minetestserver' into 'minetest.6' ?
Except the complaint during make package, it works, any advise ?

Reply via email to